
Application Note

1  Introduction

As data rates and design complexity continues to increase, signal integrity becomes an integral part of the design 
and verification process. At first glance, one might assume that because digital signals are represented by discrete 
voltage (or current) levels, signal integrity may not be of major concern to digital designers. However, digital signals 
are fundamentally analog in nature, and all signals are subject to effects such as noise, distortion, and loss. Over 
short distances and at low bit rates, a simple conductor can transmit digital signals reliably without much distortion, 
but at high bit rates and over longer distances or through various media, various effects can degrade the electrical 
signal to the point where errors occur and the system or device fails. Today, it is common to see devices and systems 
operating at multi-GHz data rates. Digital signals being transmitted over relatively long transmission lines or through 
differing materials also present signal integrity challenges. Because of these challenges, a host of variables can affect 
the integrity of signals, including transmission-line effects, impedance mismatches, signal routing, termination schemes, 
and grounding schemes. One tool used to characterize these effects is the eye diagram. With eye diagrams, engineers 
can quickly evaluate system performance and gain insight into the nature of channel imperfections that can lead to 
errors when a receiver tries to interpret the value of a transmitted data bit.

This application note reviews basic eye diagram definitions and terminologies. It will include a measurement example 
showing how to import a S-Paramater File of a device measured by an Anritsu VectorStar VNA into AWR’s Microwave 
Office application to generate an Eye Diagram.
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1.1  Eye Diagram Fundamentals

An eye diagram is commonly used to quantify the quality of signals in high-speed digital transmissions. A common 
way to generate an eye diagram is to use an oscilloscope to overlay sweeps of different segments of a long data 
stream. When many such sweeps have been overlaid, positive and negative pulses are superimposed on each 
other producing an eye diagram, so called because the resulting image looks like the opening of an eye. 

In an ideal world, eye diagrams would look like rectangular boxes. However, since real world signals are imperfect, 
the signal transitions do not line perfectly on top of each other, and an eye-shaped diagram results. Differences in 
timing and amplitude from bit to bit cause the shape of eye to change. By interpreting these changes in the eye 
diagram, engineers can easily view signal impairments in terms of amplitude and time distortion.

For this application note, instead of using an oscilloscope, we will use a software signal modeling tool, AWR’s 
Microwave Office, to generate the eye diagram. The Device-Under-Test (DUT) will be simulated by an SnP file 
generated by using an Anritsu VectorStar VNA to measure the s-parameters of the DUT.

1.2  Introduction to Histograms

Histograms are used to statistically analyze time and 
amplitude data of eye diagrams, offering important 
computational information when observing impairments 
in high-speed digital signals. This next section will 
highlight the key statistical definitions that formulate the 
basis of eye diagram measurements.

Mean and standard deviation are two important aspects 
of the time and amplitude distortion in a high-speed 
digital data stream. For a definition of these terms, 
consider the normal distribution shown in Figure 1. 
According to this graphic:

• Mean is the sum of data values divided by the number of values

• Standard Deviation, two sigma, is ±1σ, ±34 percent (or 68 percent) of mean

• Standard Deviation, six sigma, is ±3σ, ±49.85 percent (or 99.7 percent) of mean

The mean of a data set is simply the arithmetic average of the values in the set. It is obtained by summing the 
values and dividing by the total number of values. The standard deviation is a measure of the spread of data.

The 2σ (2 sigma) standard deviation is approximately 68 percent of data points within ±1σ of the mean for a 
normal distribution. The 6σ standard deviation is approximately 99.7 percent of data points within ±3σ of the mean 
for a normal distribution.

If many data points in a histogram are close to the mean, then the standard deviation is small. On the other hand, 
if many data points are far from the mean, then the standard deviation is large. When all data values are equal, 
the standard deviation is zero. It is important to understand these terms as they will play an important part in the 
upcoming amplitude and time distortion definitions.

Figure 1: This graph depicts a “normal” distribution of data
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1.3  Eye Diagram Terminology

A number of terms are used to describe amplitude and time characteristics for eye diagrams. Amplitude and time 
distortion terms are typically based on calculations from histogram data derived from the eye diagram.

These terms include:

One Level
The one level in an eye diagram is the mean value of a logic one. The actual computed value of the one level 
comes from the histogram mean value of all the data samples captured inside the middle 20% (40 to 60% points) 
of the eye period.

Zero Level
The zero level in an eye diagram is the mean value of a logic zero. The zero level is computed from the same 40 
to 60% region of the baseline area during the eye period as the one level. The actual computed value of the zero 
level comes from the histogram mean value of the data captured inside the middle 20 percent of the eye period.

Eye Amplitude
Eye amplitude is the difference between the one and zero levels. The data receiver logic circuits will determine 
whether a received data bit is a “0” or “1,” based on the eye amplitude. The calculation values used are the mean 
values of the one and zero histograms, measured during the middle 20 percent region of the eye crossings.

Eye Height
Eye height is a measure of the vertical opening of an eye diagram. An ideal eye opening measurement would be 
equal to the eye amplitude measurement. For a real eye diagram measurement, noise on the eye will cause the 
eye to close. As a result, the eye height measurement determines the eye closure due to noise. The signal to 
noise ratio of the high speed data signal is also directly indicated by the amount of eye closure. The definition for 
eye height is derived from computing the difference between the inner 3σ points on the inside of the histograms of 
the one and zero levels.

The eye amplitude and eye height definitions are important amplitude terms since the data receiver logic circuits 
will ultimately determine whether the data bit is a “0” or “1,” based on the eye amplitude. Furthermore, because 
any data bits scattered beyond the 3σ points into the open eye will indicate a possible error in the detection, the 
BER is dependent on the eye height.

Eye Crossing Percentage
The eye crossing percentage is a measure of the amplitude of the crossing points relative to the one and zero 
level. It provides a clear indication of how well the system’s data pulse symmetry is performing. 
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Figure 2: Eye Diagram Terminology
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To determine the eye crossing percentage, the one level, zero level and crossing level must first be found using 
histograms. The crossing level is determined by taking the mean value of a thin vertical histogram window centered 
on the crossing point. The crossing percentage is then calculated using the following equation:

Eye Crossing Percentage = 100 *
crossing level – zero level

one level – zero level( )
Eye crossing percentage is valuable for measuring amplitude distortions caused by differences in the one- and 
zero-level durations. It also reveals pulse symmetry problems for diagnosis. When the eye crossing symmetry 
value deviates from the perfect 50 percent point, the eye closes, which degrades BER.

Bit Period
The bit period is a measure of the horizontal opening of an eye diagram at the crossing points of the eye and is 
usually measured in picoseconds for a high speed digital signal (i.e., 200 ps is used for a 5Gbps signal). The data 
rate is the inverse of bit period (1 / bit period). The bit period is commonly called the Unit Interval (UI) when 
describing an eye diagram. The advantage of using UI instead of actual time on the horizontal axis is that it is 
normalized and eye diagrams with different data rates can be easily compared.

Eye Width
Eye width is a measure of the horizontal opening of an eye diagram. It is calculated by measuring the difference 
between the statistical mean of the crossing points of the eye. Sometimes defined as (mean right -3*sigma) - 
(mean left + 3 sigma).

Rise Time
Rise time is a measure of the mean transition time of the data on the upward slope of an eye diagram. The 
measurement is typically made at the 20 and 80 percent or 10 and 90 percent levels of the slope.

Fall Time
Fall time is a measure of the mean transition time of the data on the downward slope of an eye diagram. The 
measurement is typically made at the 20 and 80 percent or 10 and 90 percent levels of the slope.

Jitter (RMS and Peak-to-Peak)
Jitter is the time deviation from the ideal timing of a data bit event and is perhaps one of the most important 
characteristics of a high speed digital data signal. To compute jitter, the time deviations of the transitions of the 
rising and falling edges of an eye diagram at the crossing point are measured. Fluctuations can be random and/or 
deterministic. The time histogram of the deviations is analyzed to determine the amount of jitter. The peak-to-peak 
jitter is defined as the full width of the histogram, meaning all data points present. RMS jitter is defined as the 
standard deviation of the histogram. The units for a jitter measurement on a high speed digital signal are normally 
in picoseconds.

2  Measurement Example

For this example measurement, the following equipment and Software was used:
• Anritsu MS4647B VectorStar VNA

• WildRiver Technology CMP-28 Channel Modeling Platform (DUT)

• AWR Microwave Office 11.01 with Nonlinear Simulator (MWO-2xx)

2.1  Measurement Procedure

The first step in creating the eye diagram is to make S-Parameter measurements of your Device Under Test (DUT).

1. Make S-Parameter Measurements on the VectorStar VNA 

a. Perform 12-term 2 port calibration for the desired S-Parameter measurements on the VectorStar

b. Set Frequency Range:

i.  Start = 70 kHz

ii.  Stop = 70 GHz

It is recommended to make measurements to the 5th harmonic of the clock signal to capture the full signal 
span (ie 10 Gb/s NRZ clock is 5 GHz  → 5th harmonic is 25 GHz).

c. Make S-Parameter measurements on DUT and save SnP file.

2. Start AWR Microwave Office Application
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3. Create Circuit Schematic

a. From the Menu, select: Project -> Add Schematic -> New Schematic

b. Name and create your schematic

4. Add Pseudorandom Bit Sequence Generator to schematic as shown in Figure 3.

a. Select Elements Tab

b. Select Ports -> Signals from the Elements window

c. Select PORT_PRBS and drag it into the Schematic window

5. Add SnP data file from VectorStar

a. From the Menu, select: Project -> Add Data File -> Import Data File…

b. In the Browse For File Dialog: Change File Type to Touchstone Files

c. Open the SnP file saved in step 1

6. Add SnP file as a Subcircuit in the schematic

a. From the menu bar, click on the Subcircuit Icon

b. A dialog box with the SnP file that was just imported in step 5 will open

c. Select Normal Grounding Type and press OK

d. Click inside the schematic window to place the subcircuit 

Figure 3: Add PRBS Port to Schematic
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7. Add Measurement Port

a. From the menu bar, click on the Port Icon

b. Click inside the schematic window to place the port 

c. Select the port and press “CTRL-R” to rotate it 180°

8. Connect the Schematic as shown in Figure 4.

9. Double click on the PORT_PRBS parameters to change them:

a. NSYMB = 256

b. TR = 0.1 ns (Rise Time)

c. TR = 0.1 ns (Fall Time)

10. Create Eye Diagram Graph

a. From the Menu, select: Project -> Add Graph

b. Name your Graph

c. Select Rectangular Graph Type and press Create

d. A new window with your graph will appear

Figure 4: Example Schematic
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11. Add desired measurement

a. Right Click inside Graph and select “Add New Measurement”

12. Configure the new measurement as shown in Figure 5.

a. Measurement Type = Nonlinear -> Voltage

b. Measurement = Veye

c. Data Source Name = Schematic 1 (Or whatever you named your schematic)

d. Measurement Component = Port_2

e. Click OK

Figure 5: Add Measurement Dialog

13. Run Simulation to get Eye Diagram

a. Press the Analyze button on the menu bar 
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You should now have an eye diagram that looks like Figure 6.

Figure 6: Example Eye Diagram

Next, we will see how to get eye parameters. To do this, we will create a tabular graph and add the desired 
parameters. For this example, we will add the following parameters: Eye Amplitude, Eye Corners, Eye Rise & Fall 
times, Eye Height, and Eye Width

14. Create Eye Diagram Graph

a. From the Menu, select: Project -> Add Graph

b. Name your Graph

c. Select Tabular Graph Type and press Create

d. A new window with your graph will appear

15. Add desired measurements

a. Right Click inside Graph and select “Add New Measurement”
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16. Configure the new measurement as shown in Figure 7.

a. Measurement Type = Nonlinear -> Waveform

b. Data Source Name = Schematic 1 (Or whatever you named your schematic)

c. Measurement Component = Port_2

d. Measurement = Eye_Amplitude

e. Click Apply

f. Measurement = Eye_Corners

g. Click Apply

h. Measurement = Eye_Fall_Time

i. Click Apply

j. Measurement = Eye_Height

k. Click Apply

l. Measurement = Eye_Rise_Time

m. Click Apply

n. Measurement = Eye_Width

o. Click OK

Figure 7: Add Tabular Graph Measurements

17. Run Simulation to get Eye Diagram

a. Press the Analyze button on the menu bar 
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Your tabular graph should now show the selected eye parameters like in Figure 8.

Figure 8: Tabular Graph Results

3  Summary

Understanding eye diagram measurements is important for engineers dealing with high speed digital data 
transmission technology. The eye diagram is a powerful tool for assessing the quality of high-speed digital signals 
and can be used to calculate amplitude and time distortion parameters. By importing S-parameter data from an 
Anritsu VectorStar VNA into the AWR Microwave Office application, one can easily generate simulated eye 
diagrams with varying simulation parameters to fully characterize the time and amplitude characteristics of the 
device under test.
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Notes
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