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WARRANTY
The Anritsu product(s) listed on the title page is warranted against defects in materials and
workmanship for one year from the date of shipment.
Anritsu’s obligation covers repairing or replacing products which prove to be defective during the
warranty period. Buyers shall prepay transportation charges for equipment returned to Anritsu for
warranty repairs. Obligation is limited to the original purchaser. Anritsu is not liable for consequential
damages.

LIMITATION OF WARRANTY
The foregoing warranty does not apply to Anritsu connectors that have failed due to normal wear. Also,
the warranty does not apply to defects resulting from improper or inadequate maintenance by the
Buyer, unauthorized modification or misuse, or operation outside of the environmental specifications of
the product. No other warranty is expressed or implied, and the remedies provided herein are the
Buyer’s sole and exclusive remedies.

DISCLAIMER OF WARRANTY 
DISCLAIMER OF WARRANTIES. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE
LAW, ANRITSU COMPANY AND ITS SUPPLIERS DISCLAIM ALL WARRANTIES, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, WITH REGARD TO THE
SOFTWARE PRODUCT. THE USER ASSUMES THE ENTIRE RISK OF USING THE PROGRAM.
ANY LIABILITY OF PROVIDER OR MANUFACTURER WILL BE LIMITED EXCLUSIVELY TO
PRODUCT REPLACEMENT.
NO LIABILITY FOR CONSEQUENTIAL DAMAGES. TO THE MAXIMUM EXTENT PERMITTED BY
APPLICABLE LAW, IN NO EVENT SHALL ANRITSU COMPANY OR ITS SUPPLIERS BE LIABLE
FOR ANY SPECIAL, INCIDENTAL, INDIRECT, OR CONSEQUENTIAL DAMAGES WHATSOEVER
(INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFITS,
BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR ANY OTHER PECUNIARY
LOSS) ARISING OUT OF THE USE OF OR INABILITY TO USE THE SOFTWARE PRODUCTS,
EVEN IF ANRITSU COMPANY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
BECAUSE SOME STATES AND JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR
LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE
LIMITATION MAY NOT APPLY TO YOU.

TRADEMARK ACKNOWLEDGMENTS
The Bluetooth word mark and logos are owned by the Bluetooth SIG, Inc. and any use of such marks by
Anritsu is under license.  Other trade marks and trade names are those of their respective owners.
Windows XP and Windows Vista are registered trademarks of Microsoft Corporation.  Adobe Acrobat
and Acrobat Reader are trademarks of Adobe Systems Incorporated. 

NOTICE
Anritsu Company has prepared this manual for use by Anritsu Company personnel and customers as a
guide for the proper installation, operation and maintenance of Anritsu Company equipment and
computer programs. The drawings, specifications, and information contained herein are the property of
Anritsu Company, and any unauthorized use or disclosure of these drawings, specifications, and
information is prohibited; they shall not be reproduced, copied, or used in whole or in part as the basis
for manufacture or sale of the equipment or software programs without the prior written consent of
Anritsu Company.

UPDATES
Updates, if any, can be downloaded from the Documents area of the Anritsu web site at:
http://www.us.anritsu.com.

http://www.us.anritsu.com
http://www.us.anritsu.com
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Chapter 1 — General Information

1-1 About this Manual
This manual provides set-up and operational information on the CombiTest application and 
the MT8852B (Bluetooth) plug-in.

This manual assumes that readers are familiar with the MT8852B Bluetooth Test Set and are 
able to make RF measurements on Bluetooth Basic Rate and Enhanced Data Rate devices. 

Comments on this Manual

Every effort has been made to ensure that this manual is thorough, easy to use, and free from 
errors.  However, to ensure continued improvement, we would welcome your comments on 
this, or any other Anritsu document.

Please contact us at the address below if you have any comments, good or bad, find any errors 
or omissions, or have any suggestions on how our documentation could be improved further.

bluetooth.support@anritsu.com 

Your comments will be logged and reviewed, and whenever possible, will be reflected in a 
subsequent release of the document.

Software Versions

This manual provides details of the operation and functionality of the following software 
versions:

CombiTest platform (MX880000A): 1.1 (Build 1823.4014)

MT8852B plug-in (MX880002A): 1.2

External tool (MX880003A): 1.1

Auxiliary control tool (MX880004A): 1.0

Some of the features documented in this manual may not be available to users of earlier 
software versions.  Follow the procedure below to check the versions of the software in use.

1. Start CombiTest from the desktop shortcut or by accessing the Windows programs 
directory and selecting [CombiTest].

2. Select [Help] > [About].  Check the CombiTest version numbers that display in the 
dialog.

Conventions

The following conventions have been adopted in this manual.

Table 1-1. Notation Conventions

Item Convention

EUT The term “EUT” is used to refer to the Equipment Under Test.

[Anritsu CombiTest] The titles of windows, panes, and dialog boxes that appear within 
CombiTest are enclosed in square brackets.
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1-2 What is CombiTest?
CombiTest is a PC software application that provides a user with the capability to build test 
plans for single or multiple wireless standards and run them on Anritsu test sets.  A test plan 
is the name used within CombiTest for a number of tasks grouped together and configured by 
the user.  A task would typically involve the running of a particular measurement, although 
calibration and memory backup tasks are also available on the MT8860x plug-in.

Test plans can be saved and opened as required and can be executed in whole or in part by 
selecting the required tasks.

CombiTest Features

• Fully compatible with Tx and Rx testing using the Anritsu MT8860x WLAN Test Set 
and the Anritsu MT8852B Bluetooth Test Set.

• Plug and play functionality for supported test sets.

• Allows the user to quickly and easily build and run test plans.

• Allows the user to run an entire test plan or a number of selected tasks.

• Performs testing without the need for user input of remote command strings.

• Displays test results in a detailed test report.

• Auxiliary control plug-in allows the user to control an auxiliary device, and to display, 
format, and verify the received data.

• Runs in either Windows XP or Windows Vista (32 bit) environment.

• CombiTest platform source code available on request.

"Basic rate" Text that appears in windows or dialog boxes is enclosed in quotation 
marks when used within a body of text.

"RF Port" Text that appears on the front or rear panels of the test instrument is 
enclosed in quotation marks when used within a body of text.

> A chevron (>) may be used to indicate that the user should select the 
menu items or keys in sequential order.

Table 1-1. Notation Conventions

Item Convention
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Chapter 2 — Preparation for Use

2-1 Required Operating Environment
The following environment is required to install and run CombiTest successfully.

• Intel-based PC with Pentium processor or equivalent.

• Microsoft Windows XP with Service Pack 2 or Windows Vista (32 bit) operating system. 

• NI VISA 4.6 or later.

• English, Chinese, or Japanese language environment.

• 16 MB RAM minimum.

• PC display settings of 1024 x 768 or greater.

• GPIB remote interface:

2-2 MT8852B Requirements
This version of the CombiTest is suitable for use with the MT8852B, MT8852B-040, 
MT8852B-041, MT8852B-042, or MT8852B-043. 

MT8852B firmware version 4.16 or later is required. 

Low energy measurements are available within CombiTest only when supported by the 
MT8852B in use.  The MT8852B, MT8852B-040, MT8852B-041, and MT8852B-042 require 
option 27 to support low energy measurements.  The MT8852B-043 supports low energy 
measurements as standard but does not support Basic Rate or Enhanced Data Rate 
measurements.

2-3 Configuring the Equipment
Set up the equipment as shown in the figure below. 

Figure 2-1. Equipment Configuration
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1. Connect the EUT cable to the RF port on the front of the MT8852B.

2. If using the MT8852B to initialize the EUT, connect the RS232 HCI control interface 
lead (supplied), or USB HCI control interface lead (supplied) from the HCI control 
connector on the front of the MT8852B to the HCI interface on the EUT.

If not using the MT8852B to initialise the EUT, it must be initialized locally to accept a 
connection and enter Test Mode.

3. Connect the remote interface cable from the MT8852B to the PC running CombiTest.

4. Ensure the MT8852B is connected to the mains power supply.

5. Press the [On/Standby] key on the front panel of the MT8852B.

6. The MT8852B performs a brief power-on self test (POST).  After the POST, the 
instrument displays the Test group menu.  If a POST error occurs, information and 
available options display on the screen.

2-4 Installing CombiTest
The CombiTest software can be installed from the product CD or from the Anritsu website at 
www.us.anritsu.com/downloads.  The CombiTest installation includes the “External Tool” 
and “Auxiliary Control” plug-ins.

The “External Tool” plug-in is used to call up an external program before switching to a 
different wireless standard.  Refer to chapter 8 for details. 

The “Auxiliary Control” plug-in can be used to control an auxiliary device, and to display, 
format, and verify the received data.  Refer to chapter 9 for details.  

1. Run the CombiTest “Setup.exe” executable file.

When the file is run, the installation checks to see if Microsoft .NET Framework 3.5 is 
installed on the computer.

• If .NET Framework 3.5 is found, the installation continues and the initial 
[CombiTest] installation wizard displays.  Click [Next] to continue.

• If .NET Framework 3.5 is not found, it is installed automatically before 
continuing with the CombiTest installation.  Follow the displayed instructions to 
install the .NET Framework.

2. Read the license agreement.  If you agree to the terms select “I accept the terms in the 
License Agreement” and click [Next].

3. Specify the install location.  By default, CombiTest is installed to C:\Program 
Files\CombiTest.  Click [Next] to install to the default directory, or click [Browse…] to 
specify a different location for the installation.

4. Click [Install].  The progress of the installation is shown in the dialog.

5. Click [Finish] when installation is complete.

Note
Details of how to incorporate an auxiliary device (such as a switching mechanism) 
into the configuration are provided in chapter 9.

Note The instrument plug-ins are installed separately as detailed in section 2-5.

www.us.anritsu.com/downloads
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2-5 Installing the Instrument Plug-ins
Install the CombiTest platform before attempting to install the instrument plug-ins.  Refer to 
section 2-4 for details.

The instrument plug-ins can be installed from the product CD or from the Anritsu website at 
www.us.anritsu.com/downloads.  

1. Run the plug-in executable file (“.msi”).

2. Read the license agreement.  If you agree to the terms select “I accept the terms in the 
License Agreement” and click [Install].

3. Click [Finish] when installation is complete.

Note

New versions of the CombiTest plug-ins are periodically made available on 
Anritsu’s website at www.us.anritsu.com/downloads.  The plug-ins can be 
downloaded independently and used to replace earlier versions installed with the 
CombiTest platform. 

www.us.anritsu.com/downloads
www.us.anritsu.com/downloads
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Chapter 3 — CombiTest Overview

3-1 Starting CombiTest
Double-click the [CombiTest] icon generated on the desktop during installation, or select 
[CombiTest] from within the programs section of the Windows [Start] menu.

3-2 CombiTest Interface
The main [Anritsu CombiTest] window displays when CombiTest is started.

The CombiTest interface is split into three panes:

A: The [Plug-ins] pane displays the installed instrument plug-ins.  Each plug-in contains 
measurement tasks that are selected as required to build a test plan.  The plug-ins are 
installed after first installing the CombiTest platform.  At present two instrument 
plug-ins are available; more will be added as they become available.  Users can install 
any or all of the available plug-ins.  The [Plug-ins] pane can be hidden by clicking 
[Show/Hide Plug-ins] in the toolbar.

B: The [Test Plan] pane is used to build and configure the test plan.  Test plans are 
constructed by selected the required components from the [Plug-ins] pane. 

C: The [Progress] pane displays status information for the test plan being executed.

Figure 3-1. [Anritsu CombiTest] Window
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3-3 What is a Test Plan?
A test plan is the name used within CombiTest for a number of tasks grouped together and 
configured by the user.  A task would typically involve the running of a particular wireless 
test, although calibration and memory backup tasks are also available for certain wireless 
standards.  Test plans can be saved and opened as required and can be executed in whole or 
in part by selecting the required tasks.

3-4 Building a Test Plan
This section explains the methods and rules dictating how test plans can be started and 
expanded.  Full step-by-step details on how to build and configure a test plan are provided in 
chapters 4 to 6.  

Test plans are created by selecting components from the [Plug-ins] pane for transferal to the 
[Test Plan] pane.  Components can be transferred by double-clicking or by drag-and-drop.

Double-Clicking

1. Double-click a branch at any level in the [Plug-ins] frame. The branch and all its 
parents  are immediately added to the [Test Plan] pane beneath “New”.

2. Repeat this process to add further branches to the test plan.

Drag-and-Drop

1. Click the branch of the appropriate instrument plug-in, e.g., “MT8852B”, drag it to the 
[Test Plan] pane, and drop on the “New” branch.  The branch is immediately added to 
the [Test Plan] pane beneath “New”.

2. In the [Plug-ins] pane, display the contents of the plug-in by clicking [+] on the 
appropriate branch.

3. Click the next sequential branch e.g., “Bluetooth”, drag it to the [Test Plan] pane, and 
drop on the branch added in the previous step.  The branch is immediately added to the 
[Test Plan] pane. 

4. Repeat this process to add further branches to the test plan, one branch at a time.

Note
A message displays if a component cannot be added at the selected location in 
the test plan. In this situation, follow the displayed instructions to first select or 
create a branch to which the new branch can be added.

Note

Branches can be added only if they are of an equivalent hierarchical level to the 
selected branch, or if they are an immediate child.  Always target the drop at the 
specific point in the test plan where the branch is to be added.  

The mouse pointer changes to a prohibited sign ( ) if the location is incompatible.
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Chapter 4 — Remote Configuration

4-1 GPIB Configuration
A GPIB connection must be established between the MT8852B and the PC running 
CombiTest.

1. Check that the MT8852B has finished booting up and that the GPIB cable for remote 
operation is in place between the PC and the MT8852B.

2. Start CombiTest and double-click “MT8852B” in the [Plug-ins] pane.  An “MT8852B” 
branch appears in the [Test Plan] pane as shown in the figure below.

Figure 4-1. Test Plan with MT8852B Branch
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3. Double-click the “MT8852B” branch in the [Test Plan] pane or right-click and select 
[Configuration...] from the pop-up menu.  The [MT8852B Configuration] dialog displays 
as shown below.

4. Accept the GPIB address as is, or change it if required, and click [OK] .

Figure 4-2. [MT8852B Configuration]
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Chapter 5 — Configuring the System

5-1 Calibration
Some devices may need calibration before measurements can be made.  If calibration is 
required, CombiTest includes an EUT control interface that allows Dynamic Link Library 
(DLL) files to be registered within CombiTest.  Once registered, the DLLs can be selected to 
give the user access to pre-defined calibration sequences.

1. Download and install the appropriate control package.

2. Right-click “MT8852B” in the [Plug-ins] pane and select [Registered EUTs] from the 
pop-up menu.

3. Click [Add...] in the [Registered EUTs] dialog and locate the DLL installed in step 1.  
The selected DLL appears in the dialog as shown in the example below.

Note
Contact Anritsu at bluetooth.support@anritsu.com for full details of the control 
packages currently available.

Figure 5-1. [Registered EUTs] Dialog

Figure 5-2. [Registered EUTs] Dialog with DLL 
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4. Click [Close] to return to the main [CombiTest] window.

5. Double-click the “MT8852B” branch in the [Test Plan] pane or right-click and select 
[Configuration...] from the pop-up menu.  The [MT8852B Configuration] dialog 
displays.

6. Select the control package from the “EUT Selection” drop-down as shown in the figure 
below.

7. When a control package is selected, the [Edit File...] button below the drop-down is 
enabled.  Clicking this button opens the control settings file associated with the EUT in 
question and allows the user to then make and save any changes required.  

8. Click [OK] to close the [MT8852B Configuration] dialog.

Figure 5-3. [MT8852B Configuration]
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5-2 Bluetooth Configuration
1. Double-click “Bluetooth” in the [Plug-ins] pane to add a “Bluetooth” branch to the test 

plan as shown in the figure below.

2. Double-click the “Bluetooth” branch in the [Test Plan] pane or right-click and select 
[Configuration...] from the pop-up menu.  The [Bluetooth Configuration] dialog displays 
as shown below.

Figure 5-4. Test Plan with Bluetooth Branch

Figure 5-5. [Bluetooth Configuration] Dialog
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3. Select the authentication check box if the EUT requires authentication to make a 
connection.  Select the appropriate pin length (1 to 16) and enter the PIN used in the 
“PIN Code” entry field.

4. Use the horizontal scroll bar to set the “Paging Timeout”.  Set the number of seconds 
that the MT8852B will page the EUT before timing out.  Settings at this item may be 
required to minimize delay for those users who know that a connection will not be 
established by waiting if unsuccessful within a given number of seconds.

5. Use the horizontal scroll bar to set the “Link Timeout”.  Set the number of seconds that 
the MT8852B will attempt to communicate with an EUT even when it receives no 
response.  Transmission is stopped if the MT8852B receives no response from the EUT 
after the set number of seconds has elapsed.

6. Select the required Bluetooth address source from the options available.

Manual: Select the option button and enter the Bluetooth address in full.  All EUTs 
must have the same Bluetooth  address in order to use this option.

RS232: If this option is selected, the EUT address is obtained over an RS232 cable 
connected between the "EUT Control" port on the front of the MT8852B and 
the HCI connector on the EUT.  The "Baud Rate" must be specified when 
using this setting.  The baud rate must match that of the EUT HCI interface. 
The EUT address of consecutive devices can be the same or different.

USB: If this option is selected, the EUT address is obtained over an USB cable 
connected between the "EUT Control" port on the front of the MT8852B and 
the HCI connector on the EUT.  The EUT address of consecutive devices can 
be the same or different.

Inquiry: In this mode, the Bluetooth address is acquired by inquiry when the user 
attempts to run a test.  If "Inquiry" is selected, the timeout and number of 
inquiry responses can also be specified.  The EUT address of consecutive 
devices can be the same or different.

2-Wire: For low energy device testing select 2-Wire if the EUT does not have an HCI 
interface and is to be controlled using the special Bluetooth 2-Wire interface. 
(Typically this will be a single mode device supporting Bluetooth low energy 
only.) 

7. If required, select “Display Prompt for EUT Reference Identity”.  When selected, a 
dialog displays at the start of each test plan loop prompting for input of a user-specified 
EUT identity.  The specified identity displays in the “Device(s)” column in the [Test 
Plan Reports] dialog and can be used in a “Device Identity” search.

8. Click [OK] to close the [Bluetooth Configuration] dialog.
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5-3 Script Configuration
1. Double-click any of the scripts in the [Plug-ins] pane to add a “Script x” branch to the 

test plan.  There are ten scripts available:

Script 1: “Quick Test”: This script has been configured to provide the shortest possible 
test time while still providing sufficient test coverage to ensure 
good basic RF performance of the EUT.  Test time has been 
minimized by limiting the number of packets that are 
measured for each test, and by reducing the number of bits 
tested during sensitivity measurements.    

Script 2: “Full Test”: Script 2 runs every supported test as defined in the Bluetooth 
SIG RF test specification.  This script should be used for full 
product characterization or long term soak testing.      

Scripts 3 to 10: Scripts 3 to 10 are unlocked and can be freely configured by 
the user to match requirements for test coverage and total test 
time.  The default settings for scripts 3 to 10 are the same as 
script 2.  

The “Script x” branch is added to the test plan as shown in the figure below.

Figure 5-6. Test Plan with Script 3
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2. Double-click the “Script x” branch in the [Test Plan] pane or right-click and select 
[Configuration...] from the pop-up menu.  The [Script Configuration] dialog displays as 
shown below.

3. Set the power level at which commands are sent from the MT8852B to the EUT.  The 
transmission power can be set to a value between 0 and -90 dBm.

4. If required, set up a path loss between the MT8852B and the EUT.  

Select "Fixed Offset" and enter the offset value in the adjacent entry field.

Select "Table" and select the table number (1 to 5).  Click [Edit...] to open the [Path 
Offset Table Editor] and create the table by clicking [Add...] and entering the required 
frequency and offset.

5. Click [OK] to close the [Script Configuration] dialog.

Figure 5-7. Script Configuration
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Chapter 6 — Building a Script

6-1 Adding Tests to the Script
1. In the [Plug-ins] pane, double-click the measurement group to be added (“Basic Rate”, 

“Enhanced Data Rate”, or “Low Energy”).  Each group can be expanded by clicking the 
[+] on the script branch.  The figure below shows the test plan with a “Basic Rate” 
measurement group added to script 3.

Figure 6-1. Test Plan with Basic Rate Measurement Group

Note

As described in section 1-2, scripts 1 and 2 are not user-configurable.  When a 
measurement group is added for script 1 or 2, the tests within that group are also 
automatically added to the test plan.  The component tests are grayed out to show 
that they are non-configurable.  Select a user-configurable script (3 to 10) to add 
and configure measurements as described in the steps below.
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2. Double-click the required measurements in the [Plug-ins] pane to add them to the test 
plan.  All or any of the measurements within the group can be added to the test plan as 
required.  The figure below shows the test plan with four basic rate tests added.

3. If required, repeat the steps above to add an additional measurement group (“Basic 
Rate”, “Enhanced Data Rate”, or “Low Energy”) and component tests to the test plan.  

  

The figure below shows the test plan with an “Enhanced Data Rate” group and two 
component tests added to the test plan.

Figure 6-2. Test Plan with Four Basic Rate Tests

Figure 6-3. Test Plan with Two EDR Tests
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6-2 Configuring the Tests
The test conditions and limits can be configured as required.

1.  Double-click any of the test branches in the test plan, or right-click and select 
[Configuration...] from the pop-up menu.  A configuration dialog displays for the 
selected test such as the one shown below.

2. The [Configuration] tab houses a number of test conditions that determine exactly how 
the test is performed.  The test conditions vary depending on the test in question but 
are typically used to define items such as the hopping mode, the number of packets to 
be transmitted, and whether the test will be performed in loopback or Tx mode.  
Change the settings as required or click [Default] to use the test conditions as defined 
in the Bluetooth specification.  Refer to the MT8852B Operation Manual for a detailed  
description of the test conditions.  

Figure 6-4. Output Power Test Configuration

Note
The [Configuration], [Frequencies], and [Limits] settings for the non user-
configurable scripts (scripts 1 and 2) are grayed out in the dialog to show that they 
cannot be changed by the user.



Configuring the Tests Building a Script

6-4 PN: 13000-00307  Rev. C CombiTest (MT8852B Plug-In)

3. Click the [Frequencies] tab as shown below.  

This tab displays the EUT Tx and Rx values for each of the low, medium, and high 
frequencies at which the test will be conducted.  The frequencies match the 
requirements defined in the Bluetooth specification, but can be changed by the user if 
required.  If the “Test Type” test condition is set to “Tx Mode”, the Tx and Rx 
frequencies are set to the same value.

4. Click the [Limits] tab as shown below.  

The Bluetooth specification defines a number of critical pass criteria for each test; these 
are reflected on the MT8852B through the use of limit items.  Each of the limits is set 
by default to the value as defined in the specification, but the settings can be modified 
by the user if required.

5. Click [OK] to close the configuration dialog.

6. Repeat steps 1 to 5 as required for the other measurements in the test plan.

Figure 6-5. Output Power Test Frequencies

Figure 6-6. Output Power Test Limits
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Chapter 7 — Running the Test Plan

7-1 Saving the Test Plan to the Catalog
Test plans can be saved to a catalog and opened whenever required.

1. Click   in the toolbar to display the [Test Plan Properties] dialog.

2. Enter a name for the test plan, and enter a comment if required.

3. Click [OK].  The specified name displays on the uppermost branch in the [Test Plan] 
pane.

4. Click  in the toolbar to save the test plan to the catalog.

5. Click  in the toolbar to open the catalog.  The test plan name and details are listed in 
the catalog.

7-2 Executing the Test Plan
1. Ensure that the equipment is set up correctly as explained at the start of this manual.

2. Ensure that a GPIB connection has been established as detailed in chapter 4.

3. Click the [Mode] button in the toolbar of the main [CombiTest] window.  The [Loop 
Mode] dialog displays as shown below.

4. Select whether the test plan is to be run once (“Single”), in a continuous loop 
(“Continuous”), or a specified number of times (“Count”).  The selected method displays 
in the [Mode] button in the toolbar.

5.  Run the test plan by clicking  in the toolbar of the main [CombiTest] window. 

If required, the test plan can be stopped or paused as detailed below.

Click  in the toolbar to pause the test plan immediately.

Click  in the toolbar to stop the test plan after completing the current measurement.

Click  in the toolbar to stop the test plan at the end of the current loop.  This is not 
available if loop mode is set to “Single”.

Figure 7-1. [Loop Mode] Dialog
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6. The progress of the tests displays in the [Progress] pane.  When testing is complete a 
PASSED or FAILED status displays in the [Test Plan Finished] dialog as shown below.  
If required, a user comment can be entered that appears in the report when generated.  

7-3 Executing a Selected Part of the Test Plan
If required, a specific component or section of the test plan can be executed in isolation. 

Right click the required branch in the test plan and select the [Run node/group only] 
command.  The [Run xxx node only] command executes the selected branch in isolation.  

The [Run xxx group only] command executes all selected child branches within the selected 
group.

Figure 7-2. Test Plan Finished

Figure 7-3. Run Group or Node Only
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7-4 Viewing Test Reports
When testing is complete click [View Report] in the [Test Plan Finished] dialog, or click 
[Latest Report] in the toolbar of the [CombiTest] window.   A test plan report displays such as 
shown below.

Viewing Previous Test Results

When [Save Results] is selected in the toolbar, all results acquired during testing are 
automatically written to a dedicated results database. 

Figure 7-4. Test Report
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1. Click [Reports] in the toolbar, to display the window below. 

2. Enter the "From" and "To" search dates in the entry fields provided.

3. The "Device Identity" entry field can be used to display records of scripts for a specific 
address.

4. The filter settings can be used to limit the number of reports output.  

Passed or Failed: Select to display all records of test plans that passed or failed 
the tests performed.

Passed Only: Select to display only records of passed test plans (i.e., all of 
the tests in the test plans were passed).

Failed Only: Select to display only records of failed test plans (i.e., scripts 
for which one or more of the tests ended in a failure).  

5. Click [Search] to commence the search.

6. Select a report from the list and click [Open].

Figure 7-5. [Test Plan Reports] Dialog
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Changing the Save Location

By default, the database to which test reports are saved is created within C:\Program 
Files\CombiTest\Results.cdb.  Follow the procedure below to change this location or to 
generate a new database.

1. Copy the database or generate a new one.

• Locate the default database at C:\Program Files\CombiTest\Results.cdb and 
then copy it to a new location.

• Select [File] > [New...] > [Report database] and specify a name and location for 
the new database.

2. Select [File] > [Open...] > [Report database] and select the database to be opened.

Note
Relocating the results database may be useful in order to save test data for 
multiple instruments to a single location on the network.



Viewing Test Reports Running the Test Plan

7-6 PN: 13000-00307  Rev. C CombiTest (MT8852B Plug-In)



CombiTest (MT8852B Plug-In) PN: 13000-00307  Rev. C 8-1

Chapter 8 — Creating a Test Plan for 
Multiple Wireless Standards

8-1 Using the External Tool
When creating and running a test plan with branches for more than one wireless standard 
(WLAN and Bluetooth), it may be necessary to include an “External Tool” branch such as that 
shown in the figure below.

The external tool allows the user to run an external program prior to switching to a different 
wireless standard.  This may be necessary if running utility programs or executing batch 
files.

1. Add an “External Tool” to the test plan between branches of different wireless standards 
as shown above.  

If adding the branch by clicking, select the uppermost branch of the test plan 
(“MT8852B” in the example above) before double-clicking “External Tool” in the [Plug-
ins] pane.  

If adding the branch by drag-and-drop, the “External Tool” branch should be dropped 
on to the uppermost branch of the test plan (“MT8852B” in the example above) to 
position it as shown in the figure above.

Figure 8-1. Test Plan with External Tool Dialog
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2. Double-click the “External Tool” branch in the [Test Plan] pane or right-click and select 
[Configuration...] from the pop-up menu.  The [External Tool] dialog displays as shown 
below.

3. If required, enter a description to appear on the “External Tool” branch of the test plan.

4. At “Command”, enter the command that will be executed when the test plan is run, e.g., 
“notepad.exe”.

5. At “Arguments”, enter any arguments required to pass to the command.

6. At “Initial Directory”, enter the folder from which the command will be run.  This is only 
required if the command needs to be run from a specific location.

7. Select the required text output option.

8. Click [OK] to close the [External Tool] dialog.

Figure 8-2. [External Tool] Dialog
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Chapter 9 — Controlling an Auxiliary 
Device

9-1 The Auxiliary Control Plug-In
The Auxiliary Control plug-in provides the user with the ability to control an auxiliary device.  
By including an auxiliary control branch in the test plan, the user can send commands to the 
device and, if required, display, format, and verify the received data.

The auxiliary plug-in can be configured to match the role played by the auxiliary device in the 
test environment.  One common configuration would be to use the auxiliary plug-in to control 
a switching mechanism.  The switch could, for example, be used to alternate between test 
ports on a single EUT or to alternate between multiple EUTs.  This example is shown in the 
figure below.

Figure 9-1. Using the Auxiliary Control Plug-in to Control an Auxiliary Device
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9-2 Selecting the Serial Interface
1. Add an "Auxiliary Control" branch to the test plan in the manner described earlier in 

this document.  The auxiliary control branch can be added at any point in the test plan.

2. Double-click the "Auxiliary Control" branch in the test plan to display the dialog below.

3. Select the communication method that will be used to control the auxiliary device.  
Three communication methods are supported: Ethernet, NI Visa, and Serial Port. 

4. Click [Settings...] to display the associated [Configuration] dialog.

5. Configure the interface as required.  If using NI Visa, ensure that the "Currently 
Available Resource" is set to the correct GPIB address.

6. Click [OK] to close the [Configuration] dialog.

7. Click [OK] to close the [Auxiliary Control] dialog.

9-3 Clearing the Buffer and Adding a Wait Period
If required, branches can be added to the test plan to return the auxiliary device to a known 
state, or to insert a wait period.  

1. Expand the “Auxiliary Control” > “Control” branch in the [Plug-in] frame.

2. Double-click the required “Clear” or “Wait” branch to add it to the test plan. 

The “Clear” branch is used to put the auxiliary device into a known state and clear the 
buffer.

The “Wait” branches can be double-clicked in the test plan to specify the wait period.

Figure 9-2. [Auxiliary Control] Dialog
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9-4 Sending a Command to an Auxiliary Device
1. Add a "Send" branch to the test plan in the manner described previously.

2. Ensure that the communication method has been correctly configured as described 
above.

3. Double-click the "Send" branch.

4. Click [Add] and enter the command to be sent in the [Enter Command] dialog.  If 
sending a file, select the "Send File" check box and click [File...] to locate the required 
file. The figure below shows the dialog after adding an example command (*IDN?).

5. Click [OK] to close the [Send] dialog.  The specified command displays on the file 
branch.

9-5 Receiving Data From an Auxiliary Device
1. Add a "Receive" branch to the test plan in the normal manner.

2. Double-click the "Receive" branch to display the [Receive Configuration] dialog shown 
below.

3. At the "Name" entry field, enter the name that will display in the progress window next 
to the response. 

4. Select the "Display Received Data in Progress Window" check box.

5. Select the appropriate "Receive Setting".  If the data to be received is raw byte data of a 
specific length, it may be desirable to select "Receive Data as a Fixed Size Byte Array" 
and specify the number of bytes.  For text based data, select "Receive Data as a 
Variable Length String".

6. Click [OK] to close the [Receive Configuration] dialog and then run the test plan.

Figure 9-3. [Send] Dialog with Example Command

Note
Sending a command does not return a reply unless a "Receive" branch is also 
added to the test plan as detailed below.  If a response from the auxiliary device is 
not expected, it is not necessary to add a Receive branch.
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Example

An example is provided in the test plan catalog.

1. Click the  icon in the toolbar to open the [Test Plan Catalog] dialog.

2. Select "Get Identity" and click [Open Test Plan].

3. Double-click the "Receive" branch to display the [Receive Configuration] dialog shown 
below.

In this example test case, a *IDN? command is sent to the auxiliary device.  A response 
tag of "Identity" has been set, and the check box is selected to display the received data 
in the progress window.  After running the test case, the progress window displays the 
command sent (*IDN?), the tag specified for the reply (Identity), and the response 
returned from the auxiliary device (in this case, KEITHLEY INSTRUMENTS 
INC.,MODEL 2016P,1215040,A07/  A02).

9-6 Displaying the Received Data in the Test Report
1. Follow the explanations above to create a test plan with "Send" and "Receive" branches.

2. Double-click the "Receive" branch to display the [Receive Configuration] dialog.

3. Select the "Save Received Data to Report" check box.

4. Close the [Receive Configuration] dialog and run the test plan.

5. The test plan is run and the received data added to the report as an unformatted text 
string.

Figure 9-4. [Receive Configuration] Dialog



Controlling an Auxiliary Device Formatting the Received Data in the Test Report

CombiTest (MT8852B Plug-In) PN: 13000-00307  Rev. C 9-5

9-7 Formatting the Received Data in the Test Report
1. Follow the explanations above to create a test plan with "Send" and "Receive" branches.

2. Double-click the "Receive" branch to display the [Receive Configuration] dialog.

3. Select the "Save Received Data to Report" check box.

4. Click the [Report Formatting] tab and select the "Format Received Data" check box.

5. In the "Report Format" entry field, enter the XML code used to format the received data 
in the report as required.  Instructions on how to code in XML are beyond the scope of 
this document.  There are many freely available guides on the internet (such as http://
www.w3schools.com) that provide tips and instructions on HTML, XML, and XSL.

Example

An example is provided in the test plan catalog.

1. Click the  icon in the toolbar to open the [Test Plan Catalog] dialog.

2. Select "Get Identity and Format in the Report" and click [Open Test Plan].

3. Double-click the "Receive" branch of the test plan just opened.  

The XML code visible in the "Report Format" entry field is used to partition the identity 
string returned earlier (KEITHLEY INSTRUMENTS INC.,MODEL 
2016P,1215040,A07  /A02) and to prefix each section with an appropriate heading 
("Company", "Model", "Serial", and "Version").  As can be seen in the code, the cells 
within the table are populated using XSL structured objects to reference the 
appropriate element.  

4. Click [OK] to close the [Receive Configuration] dialog.  When the test plan is run, the 
original text string is neatly formatted in the test report.

Figure 9-5. Report Formatting Code
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9-8 Verifying the Received Data
Data verification allows the user to ensure that data received from the auxiliary device 
complies with a specified set of user requirements.  Verifier expressions can be used to dictate 
that, for example, the received data is of a specific length, in a specific order, or within a 
specific range. Data can be verified using simple .Net RegEx expressions or in multiple parts 
using a combination of verifiers to match the requirements of each part (e.g., text 
comparisons, RegEx comparisons, numeric range checks).  

1. Follow the explanations above to create a test plan with "Send" and "Receive" branches.

2. Double-click the "Receive" branch to display the [Receive Configuration] dialog.

3. If required, select "Display Received Data in Progress Window", as explained above.

4. If required, select "Save Received Data to Report", as explained above.

5. Click the [Verify Received Data] tab.

6. Select "Verify Received Data".

7. If required, select "Abort Test Plan if Verify Fails".

8. Select the required verifier from the "Verifier" drop-down selection box. 

9. Enter the verifying expressions in the "Comparison Expression" entry filed.

Example

An example is provided in the test plan catalog.

1. Click the  icon in the toolbar to open the [Test Plan Catalog] dialog.

2. Select "Get Identity, Format in the Report and verify version" and click [Open Test 
Plan].

3. Double-click the "Receive" branch of the test plan just opened. 
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4. Click the [Verify Received Data] tab to display the dialog shown below.

In this example, the code within the "Comparison Expression" field is split into five 
parts, each part enclosed within a "PartVerifyConfig" element.  The five parts are used 
to verify the identity string returned earlier (KEITHLEY INSTRUMENTS 
INC.,MODEL 2016P,1215040,A07  /A02) in response to the *IDN? command.  Parts one 
and two use a StraightTextCompare to verify the company and model names.  Part 
three uses a RegExCompare to verify that the serial number starts with "1215".  Parts 
four and five use a NumericRangeCheck to verify that the component elements of the 
version number fall within the required ranges.  

5. Click [OK] to close the [Receive Configuration] dialog and then run the test plan.  

The "Receive" branch displays in green if verification is successful when the test plan is 
executed.  

The "Receive" branch displays in red if the returned data falls to comply with the 
specified verifier expressions.

 

Figure 9-6. [Verify Received Data]



Verifying the Received Data Controlling an Auxiliary Device

9-8 PN: 13000-00307  Rev. C CombiTest (MT8852B Plug-In)



CombiTest (MT8852B Plug-In) PN: 13000-00307  Rev. C 10-1

Chapter 10 — Common Procedures

This chapter provides a quick reference to a number of simple procedures with which the user 
will need to gain familiarity.  The procedures are split into groups and listed in alphabetical 
order within each group.

10-1 Test Plans

Aborting on Failure

1. Double-click the top branch of the test plan displaying the test plan name.

2. Select “Abort on failure” in the [Test Plan Configuration] dialog.

Creating

1. Select [File] > [New...] > [Test Plan] or click  in the toolbar.

2. Specify a name for the new test plan.  The specified name appears on the uppermost 
branch of the test plan. 

Deleting

1. Click  in the toolbar.

2. Click [Yes] at the confirmation dialog.

Naming

1. Select [File] > [Save as...] > [Test Plan] or click  in the toolbar to display the [Test 
Plan Properties] dialog.

2. Enter a name and comment and click [OK].  The specified name displays on the 
uppermost branch of the test plan.

Opening

1. Select  [File] > [Open...] > [Test plan] or click  in the toolbar to open the test plan 
catalog. 

2. Select the test plan to be opened.

3. Click [Open Test Plan].  The test plan appears within the [Test Plan] pane.

Saving

Select [File] > [Save] > [Test plan] or click  on the toolbar.

10-2 Test Plan Components

Deleting

1. Right-click the item in the test plan to be deleted.

2. Select [Delete] from the pop-up menu.



Test Plan Catalog Common Procedures

10-2 PN: 13000-00307  Rev. C CombiTest (MT8852B Plug-In)

Disabling

1. Right-click a branch of the test plan supporting more than one child branch.

2. Select [Subtasks...] > [Disable All] from the pop-up menu.

3.  The tick marks in all check boxes within the group are cleared to indicate that the 
component branches will not be executed during testing.

Enabling

1. Right-click a branch of the test plan supporting more than one child branch.

2. Select [Subtasks] > [Enable All] from the pop-up menu.

10-3 Test Plan Catalog

Creating

1. Select [File] > [New...] > [Catalog].

2. Specify a name and location for the new catalog in the usual manner.

3. Click  in the toolbar to open the new catalog.  The specified name displays in the title 
bar of the window. 

Opening

1. Select [File] > [Open...] > [Catalog].

2. Locate the catalog in the usual manner and click [Open].

3. Click  in the toolbar to open the catalog.  The name of the selected catalog displays in 
the title bar of the window. 

Viewing

Click  in the toolbar to open the test plan catalog. 

The catalog shows the details of all saved test plans.  Saved test plans can be deleted from the 
test plan pane without deleting the backup in the catalog.  

10-4 Report Database

Creating

1. Select [File] > [New...] > [Reports database].

2. Specify a name and location for the new database in the usual manner.

3. Click  in the toolbar to open the new database.  The specified name displays in 
the title bar of the window. 

Viewing

Click  in the toolbar to open the reports database. 
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10-5 Getting Help

Viewing the Bluetooth (MT8852B) Plug-in Operation Manual

Select [Help] > [Plug-in Manuals] > [MT8852B].

Viewing the CombiTest Plug-in Development Manual

This manual is a reference for those users wanting to build additional plug-ins.

Select [Help] > [API Manuals] > [Plug-in Development Manual].

Viewing the CombiTest Interface Manual

This manual is a reference for those users wanting to execute test plans within their own 
applications.

Select [Help] > [API Manuals] > [CombiTest Interface Manual].
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Appendix A — GPIB Setup
The following GPIB interface properties are recommended for reliable GPIB communication 
with the MT8852B Bluetooth Test Set.  The interface properties are expressed in the terms 
used by the National Instruments GPIB ISA and PCI cards and drivers for Windows and 
DOS.

For details of how to set up and configure the National Instruments GPIB card, refer to the 
installation information supplied with the card itself.

A-1 General Settings 
GPIB Interface ID: GPIB0

Secondary Address: NONE

System Controller: YES

I/O Timeout: 13 (10 seconds)

Autopolling: YES

A-2 Termination Settings
Set EOI at End of Write: YES

Terminate Read on EOS: NO

EOS Byte: 0x0A (10 decimal)

8-bit EOS Compare: YES

Set EOI with EOS on Write: YES

A-3 Advanced Settings
HS488 Cable Length: 0 (Disabled)

Parallel Poll Duration: 0 (2 msec)

Assert REN when SC: YES

Bus Timing: 2 (500 nsec)
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Appendix B — Terminology Glossary
Table B-1. Terminology Glossary

Acronym Meaning

EUT Equipment Under Test.  The equipment being tested by the MT8852B.

GPIB General Purpose Interface Bus.  The communication link required to 
enable LANTest to acquire data from the MT8852B.  A GPIB interface 
card and lead must be fitted to the PC to connect to the MT8852B.

Test plan A group of tasks configured to meet requirements and run 
consecutively without further interaction from the user.

IEEE The Institute of Electrical and Electronic Engineers that develop and 
maintain the varying WLAN standards.

PER Packet Error Rate

DLL Dynamic Link Library
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Appendix C — Technical Support
Although every effort has been made to ensure the quality and reliability of this product, 
there may be times when operation difficulties are experienced and technical support is 
required.

C-1 Contacting Support 
For immediate assistance contact your local Anritsu sales engineer or field application 
engineer.  A list of all regional offices can be found on our internet site at the following 
location: http://www.anritsu.com/contact.asp.

C-2 Reporting Problems
Technical support can also be obtained by sending an e-mail to our technical support team at 
bluetooth.support@anritsu.com.  Please include the details below.

• Test instrument serial number

• Description of the problem

• List of error messages displayed

• Description of procedure to replicate the problem

• Details of efforts already made to correct the problem

Every effort will be made to ensure that a response is provided within three working days.

C-3 Anritsu Service Centers
A list of all Anritsu service centers is provided on our internet site at the following location: 
http://www.anritsu.com/contact.asp.

http://www.anritsu.com/contact.asp
mailto:bluetooth.support@anritsu.com
http://www.anritsu.com/contact.asp
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Appendix D — PC Regional Settings
The CombiTest software is designed to operate on Windows XP or Windows Vista (32-bit) in 
an English, Japanese, or Chinese language environment.  Performance cannot be guaranteed 
when installed on any other system.   

Operation difficulties may be experienced if CombiTest is operated on a PC running in a 
language environment, such as Swedish and German, where a comma is used as the decimal 
symbol (e.g., 3,6), instead of a point (e.g., 3.6).

Follow the appropriate procedure below to change the decimal symbol to a point (.).

D-1 Windows XP
1. Open the [Control Panel] from the Windows [Start] menu.

2. Open [Regional and Language Options].

3. Click the [Customize...] button.

4. Select the point (.) setting from the "Decimal Symbol" drop-down field.

D-2 Windows Vista
1. Open the [Control Panel] from the Windows [Start] menu.

2. Open [Regional and Language Options].

3. Click the [Formats] tab.

4. Click [Customize this format...].

5. Click the [Numbers] tab.

6. Select the point (.) setting from the "Decimal symbol" drop-down field. 
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