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Notes On Export Management
This product and its manuals may require an Export License or approval by the government of the product 
country of origin for re-export from your country.

Before you export this product or any of its manuals, please contact Anritsu Company to confirm whether or 
not these items are export-controlled.

When disposing of export-controlled items, the products and manuals need to be broken or shredded to such a 
degree that they cannot be unlawfully used for military purposes.

For the latest service and sales contact information in your area, please visit:
https://www.anritsu.com/en-US/test-measurement/contact-us

https://www.anritsu.com/en-US/test-measurement/contact-us
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Chapter 1 — General Information

1-1 Introduction
Developers use the easyTest Tools PC application to create a test sequence file that will be installed onto an 
Anritsu handheld instrument via a USB memory device. Once installed, the easyTest file will display 
on-screen step-by-step instructions, simplifying the process of operating the instrument and completing 
measurements quickly and accurately. 

easyTest Tools™ (eTT) files provides a library of commands and a drag-&-drop tool for creating a test sequence 
to be used with Anritsu Handheld instruments. 

The easyTest Tools™ PC application can be downloaded as part of the Anritsu Tool Box and used to create 
your own custom test sequences. The easyTest files can be downloaded from the Anritsu web site at: 
https://www.anritsu.com/en-us/test-measurement/products/ett. 

System Requirements

Anritsu software tools run on a PC using Windows operating systems. The minimum PC requirements are:

• 1 GB of RAM

• 1 GB of available hard disk space

Instruments Supported by easyTest Tools (eTT)

To identify the instruments supported by easyTest Tools, visit the Anritsu product page for easyTest Tools at: 
https://www.anritsu.com/en-us/test-measurement/products/ett

1-2 Installation
easyTest Tools is a software component of the Anritsu Tool Box download. Go to the Anritsu download library 
to install the latest Anritsu Tool Box software: 
https://www.anritsu.com/en-US/test-measurement/support/download.

• If you select the Full Installer, internet access is not required while running.

• If you select the Web Installer, internet access is required while running.

Select the installation program. The installation will start. Follow the on-screen instructions. The installation 
process will include several installation screens as shown in Figure 1-1.

Note
eTT file formats compatible with some older firmware versions. It is recommended that you update 
your instrument’s firmware. Firmware can be found at the Anritsu website. 

https://www.anritsu.com/en-us/test-measurement/products/ett
https://www.anritsu.com/en-US/test-measurement/support/downloads
https://www.anritsu.com/en-us/test-measurement/products/ett
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During the installation process, an instruction screen will prompt you to choose the program(s) to download. 
See Figure 1-2. Select easyTest Tools. Note that you may download more programs from the Anritsu Tool Box 
suite. The selected program(s) will be loaded to your system tray and show as shortcut icons on your desktop. 

Figure 1-1. Anritsu Tool Box Installation Process

Figure 1-2. Anritsu Toolbox Program Selection Screen
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Instrument Family Selection

After launching easyTest Tools, the easyTest Instrument Family Selector dialog opens as shown in Figure 1-3. 
Select the radio button that corresponds to your model instrument for the easyTest file.

1-3 Load the easyTest File Into the Instrument
1. After downloading the easyTest file (.ett) from the Anritsu web site, copy it from your browser download 

folder onto a USB memory device (double clicking the easyTest file generally displays text/code and will 
not install the easyTest file into your instrument).

2. Copy the easyTest file from the USB memory device into the instrument. Refer to your instrument user 
guide for file copying operations between a USB memory device and the instrument.

Figure 1-3. Instrument Family Selector Dialog

Note

Once the easyTest file is copied to the instrument’s internal memory, the file can easily be saved as a 
favorite on the instrument main menu by pressing and holding the easyTest file name until the menu 
grid is displayed, and then the desired location for the easyTest icon can be selected. The easyTest 
icon will be named the same as the copied file name. Make sure the easyTest file is saved into the 
instruments internal memory before creating a shortcut, and then use the internal memory saved 
easyTest file to create a shortcut.
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Execute the easyTest File Test Sequence

1. Press the Menu button on the instrument keypad. 

2. Execute the easyTest file in one of two ways:

• If you have saved the file as a favorite, press the easyTest icon.

• If you want to select the easyTest file from a list of saved easyTest files, press the easyTest icon on 
the menu of the Anritsu handheld instrument, then select the desired easyTest file (.ett) from the 
Recall dialog using the up/down arrow buttons or knob, and then press Enter. The first step of the 
easyTest sequence will then be executed.

3. Follow the instruction prompts on the Status/Instruction bar and press either the Next Step button on 
the touch screen (shown below) or press the right arrow button on the instrument to continue to the next 
step.

4. After completing the last step, an Attention dialog will inform you that the easyTest sequence is 
complete.

Once the model group has been selected and launched, the opening GUI applications screen appears as shown 
in Figure 1-4. 

1. Tool Bar

2. Menu Bar

3. Command Selections panel

4. Command Sequence panel

5. Command Detail panel

6. Repeat Script panel

Figure 1-4. easy Test Tools Graphic User Interface

1
32 54
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Toolbar

The Toolbar tools are displayed as buttons and task-related groups. For example, the easyTest Tool toolbar 
consists of the button to select the instrument’s connection. 

Toolbars float as independent panels so you can move them anywhere within the toolbar area. The toolbar area 
is defined the top and left side of the easyTest Tools window. Note that it also displays the family of 
instruments selected in the easyTest Instrument Family Selector.

Table 1-1. Toolbar Buttons Definition

Open
Opens the Open dialog to load an easyTest file (.eTT) 
into easyTest Tools. 

Save Saves the easyTest file to the PC.

Print
Opens the Print Preview dialog with the commands and 
command sequence displayed in table form for printing.

Help Opens easyTest Tools Help.

Select Instrument 
Connection

Opens the Instrument Connection Settings dialog 
allowing you to set the connection type of the 
instrument. If the connection is Ethernet, an entry 
window is available to type in the IP address. 

Instrument 
Requirements

Displays the instrument details:
Instrument Family, Instrument Model, Required 
Hardware Options, Frequency Range and Required 
Modes 



1-3 Load the easyTest File Into the Instrument General Information

1-6 PN: 10580-00424  Rev. B easyTest Tools UG

Menu Bar

The menu bar extends across the top of the application window and includes three menu categories: File, 
Settings and Help. 

File Menu

From the Menu Bar, open the File menu to display the following:

• New: Clears the Command Sequence and Command Detail panels.

• Open: Load an easyTest file (.ett) into easyTest Tools.

• Save: Saves the easyTest file to the PC.

• Save As: Allows you to name or rename an easyTest file before saving it to the PC.

• Print: Opens the Print Preview dialog with the commands and Command Sequence displayed in table 
form for printing.

• Exit: Closes the easyTest Tools application.

Settings Menu

From the Menu Bar, open the Settings menu to display the following:

• Instrument Connection Settings – Opens the Instrument Connection Settings dialog allowing you to set 
the connection type of the instrument. If Ethernet is the connection selected, an entry window is 
available to type in the IP address.

Help Menu

From the Menu Bar, open the Help menu to display the following:

• Contents: Opens the easyTest Tools Help file.

• Opens the easyTest Tools About window showing version and copyright information.

Figure 1-5. Menu Bar

Figure 1-6. File Menu
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1-4 Command Panels 
 The command panels include:

• Command Selections: This panel provides the list the commands available: Display Image, Recall Setup, 
Prompt, and Save.

• Command Sequence: This panel displays the commands selected from the Command Selections panel 
and lists them in the order selected.

• Command Details: This panel displays a user interface for the next command selected from the 
Command Selections panel.

• Repeat Script: This panel allows a user to repeat commands. 

Commands chosen from the Command Selections panel are then dropped into the Command Sequence panel. 
The commands listed in the Command Sequence panel perform in the in the order in which they are dropped 
and listed. When the selected commands are dropped in the Command Sequence panel, they are also dropped 
into the Command Detail Panel. The Command Detail panel provides the user a simple means to create a 
script for each command. Command interface details are described in Section 2-2 “Command Detail” 
on page 2-1.

Command Selections 

To select a command, go to the Command Selections panel and click on the command. 

The commands available from the Command Selections panel are listed below:

• Display Image: See Section “Display Image Command” on page 2-1.

• Recall Setup: See Section “Recall Setup Command” on page 2-4.

• Prompt: See Section “Prompt Command” on page 2-2.

• Save: See Section “Save Command” on page 2-5.

Figure 1-7. Command Selections panel
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Command Sequence Panel

The list of commands chosen from the Command Selections panel are dropped in the order chosen into the 
Command Sequence panel. The order created provides the test sequence loaded into an Anritsu Handheld 
instrument. The highlighted command is the command displayed in also dropped into the Command Detail 
panel. Note that a command can be selected and displayed multiple times with each command providing 
different user defined detail.

The number of commands allowed in creating a Command Sequence is limited to one hundred. When setting 
multiple command sequences, steps 31 to 100 will be orange in color.

Command Detail Panel

Select a command from the Command Sequence panel so that it drops into the Command Detail panel. Here, 
the user can edit the parameters of the chosen command. 

Figure 1-8. Command Sequence panel

Figure 1-9. Command Detail panel
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Repeat Script

Allows the user to set a given eTT file to automatically repeat. Enter the desired number of times the script is 
to repeat in the “Number of Times to Repeat” entry box. Click the Active check box to run Repeat Script. 
Entering 0 will yield infinite repetitions.

Figure 1-10. Repeat Script panel
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Chapter 2 — Command Panels Overview

2-1 Introduction
Developers use the Command panels to create a test sequence file that will be installed onto an Anritsu 
handheld instrument. 

2-2 Command Detail 
Each command selected from the Command Sequence panel drops into and can be edited in the Command 
Detail panel. 

Editing the Commands

Once a command is dropped into the Command Detail panel, each command opens a parameter field that is 
used to define each command application. 

Display Image Command

Displays the image set in the Command Detail panel that will be used during the command sequence to better 
convey to the instrument user what is to be done. 

Prompt Text (Characters limited)

Keep the default message “Display Image” or enter another message, an action, or expected result to be viewed 
by the field technician.

Figure 2-1. Display Image
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Source File: 

1. Press the Browse button to load an image file. 

• The Open dialog opens.

2. Select the desired image file and press Open.

• The directory and filename are listed in the status box. The image is displayed in the Image 
Preview panel.

Prompt Command

Provides a message entry field for the instrument user. See Figure 2-2

Prompt Text 

Enter a message, an action, or expected result to be viewed by the instrument user. 

Lock Instrument

Check the Lock Instrument box:

• The instrument user will only be allowed to press the right arrow button or Esc button. An icon of a 
closed lock will be displayed on the Status/Prompt bar of the instrument. If unchecked, “unlocked”, the 
instrument user will be able to press all of the keypad buttons. An icon of an open lock will be displayed 
on the Status/Prompt bar of the instrument.

Apply Delay (Seconds)

The text prompt at the start of the screen will be displayed for at least this many seconds before the user is 
allowed to advance the script. 

• Can be useful if the test requires allowing the instrument to sweep for a while before continuing.

Figure 2-2. Prompt
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Below is an example of a newly created Prompt text that becomes available as a new command in the 
Command Sequence column.

To create a new Command:

1. Select Prompt from the Command Selections column.

• The Prompt command drops into the Command Detail column.

2. Enter the new name of the command in the Prompt Text Field.

• The “Prompt” display changes to the Prompt Text entry and appears in the Command Sequence 
Column as shown in Figure 2-3. 

Figure 2-3. New Command Prompt Example
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Recall Setup Command

Recall setup allows you to retrieve a previously created measurement setup file (.stp) from the PC. Or, you can 
retrieve the current measurement state of Anritsu handheld instrument. These parameters are saved to the 
easyTest file for use in the Recall Setup step on the instrument.

Set the following command parameters 

Prompt Text: (Characters limited)

Keep the default message “Recall Setup” or enter another message to be viewed by the instrument user.

Load Instrument Setup File from…

From PC Tab:

1. Press the Browse… Button.

• The Open dialog opens to select a measurement .stp file from the PC.

2. Select a .stp file.

3. Press Open.

• The contents of this file will be used in the Recall Setup step when running on the instrument.

Current Instrument State Tab

1. Press the Load Setup… button.

• The current measurement setup parameters are copied to the easyTest file. The Save As dialog 
opens to save a copy of these parameters to the PC.

2. Enter a name.

3. Press Save.

View Loaded Setup… Button

Press this button to view the contents of the Setup file that will be used by the Recall Setup command on the 
instrument.

Figure 2-4.



Command Panels Overview 2-1 Introduction

easyTest Tools UG PN: 10580-00424  Rev. B 2-5

Auto Advance

This step will advance to the next step without user interaction. For example, the setup file will be recalled, 
and the script will advance to the next step once the setup is fully recalled. By default the user will need to 
manually click next to advance.

Save Command

Saves the current measurement setup or current screen display to the instrument using the instrument’s Save 
function. It can be done automatically or manually. 

Prompt Text: 

• (Characters limited): Keep the default message “Save” or enter another message to be viewed by the 
instrument user. 

Base Filename: 

• Enter a name that will be placed in the Filename: entry box of the Save dialog of the instrument.

Save Mode and Save Format:

• Automatic and Measurement: If this pair is selected, the name in Base Filename: will be placed into the 
Filename: in the Save dialog with File type: set to .dat and then saved.

• Automatic and Screenshot: If this pair is selected, the name in Base Filename: will be placed into the 
Filename: in the Save dialog with Filetype: set to .jpg and then saved.

• Manual & Measurement: If this pair is selected, the Save dialog is opened, the name in Base Filename: is 
placed into the Filename:, Filetype is set to Measurement, but the user will be allowed to make edits to 
those categories if necessary. Press the Enter button to save the file and close the Save dialog.

• Manual & Screenshot: If this pair is selected, the Save dialog is opened, the name in Base Filename: is 
placed into the Filename:, Filetype is set to JPEG, but the user will be allowed to make edits to those 
categories if necessary. Press Enter to save the screen image and close the Save dialog.

Figure 2-5. Save Setup
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Clear Command Sequence Panels

To clear the Command Sequence panel and the Command Detail panel:

1. Go to the File Menu Bar, see Section “File Menu” on page 1-6.

2. Select New.

Removes the Command Sequence panel and the Command Detail panel commands. If the Command Sequence 
has not been saved, a Warning dialog will open to confirm that you want to continue. See Figure 2-6.

Deleting a Command

A command can be deleted from the Command Sequence panel by choosing the command and pressing the 
delete key on your keyboard.

Figure 2-6. Warning Dialog
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Chapter 3 — Using easyTest Tools

3-1 Introduction
When launching the easyTest Tools program, a dialogue opens that prompts you to choose the family of 
instruments you will be working with. See Figure 1-3, “Instrument Family Selector Dialog” on page 1-3. Files 
“loaded” and “saved” will retain the file type for the instrument family selected.

Create an easyTest File

1. Drag the desired step/s from the Command Selections panel into the Command Sequence panel. Remove 
unwanted commands from the Command Sequence panel by highlighting that command and pressing 
the Delete button on the PC keyboard.

2. Set the order of the commands in the Command Sequence panel by clicking on a command and dragging 
it to the desired 1-2-3…order.

3. If a command’s parameters need editing, click on it in the Command Sequence panel and it will be 
displayed in the Command Detail panel. Change its parameters accordingly. (See Display Image, Recall 
Setup, Prompt, and Save.).

4. Click Save As… in the File menu.

Setup Connection to the Handheld Instrument

1. Click Instrument Connection Settings… in the Settings menu or press Select Instrument Connection 
icon on the easyTest Tools toolbar. 

2. Select either USB or Ethernet. If Ethernet is selected, enter the IP address of the instrument in the text 
box.

3. Press the Save Settings button when done.

Load the easyTest File into the Instrument

1. Copy the eTT file from the PC onto a USB Memory Stick. 

2. Copy the eTT file from the USB Memory stick into the instrument. Please refer to your instruments 
product page at: https://www.anritsu.com/en-US/test-measurement 

Execute the easyTest File Test Sequence

1. Press the Menu button on the instrument keypad. 

2. Press the easyTest icon in the menu of the Anritsu Handheld instrument. 

• The Recall dialog opens.

3. Select an easyTest file (.ett) using the up/down arrow buttons or knob.

4. Press Enter.

• The first step of the easyTest test sequence is executed.

5. Follow the instruction prompts on the Status/Instruction bar. Press either the “Next Step” button on the 
touch screen or the right arrow button on the instrument to continue to the next step.

6. After completing the last step, an Attention dialog will inform you that the easyTest file sequence is 
completed and closing.

https://www.anritsu.com/en-US/test-measurement
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Open Files

There are two methods for opening easyTest files -

Opening Files From the File Menu

1. Press Open… in the File menu. 

• The Open dialog opens.

2. Select an .ett file.

3. Press the Open button.

4. The file is opened in eTT and its commands are loaded into the Command Sequence panel with the 
filename displayed next to the Command Sequence title. The directory and filename will be displayed on 
the menu bar after Settings. Also, the command highlighted in the Command Sequence panel will be 
displayed in the Command Detail panel ready for editing. 

Opening Files From the File Main Toolbar

1. Press Open icon on the main Toolbar. 

• The Open dialog opens.

2. Select an .ett file.

3. Press the Open button.

4. The file is opened in eTT and its commands are loaded into the Command Sequence panel with the 
filename displayed next to the easyTest Tools name on the title bar. The directory and filename will be 
displayed on the menu bar after Settings. Also, the command highlighted in the Command Sequence 
panel will be displayed in the Command Detail panel ready for editing.

Save File Functions

Save… in the File menu and the Save icon on the main Toolbar saves the current Command Sequence to a file. 

Saving From the File Menu

Save…

1. Click Save… in the File menu.

• The Save As dialog opens.

2. Enter a name in the File name text box.

3. Press the Save button.

Save As…

1. Click Save As… in the File menu.

• The Save As dialog opens.

2. Enter a name in the File name text box.

3. Press the Save button. 
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Saving From the Toolbar

1. Press the Save icon on the Main toolbar.

• If the Command Sequence was previously saved to file, then the new content is updated and saved 
immediately.

• If the Command Sequence is new and not previously saved - The Save As dialog opens.

2. Enter a name in the File name: text box.

3. Press the Save button.

Print

There are two methods for printing easyTest files –

Printing From the File Menu

1. Click Print… in the File menu. 

• The Print Preview dialog opens.

2. Press the Print button.

• The Print dialog opens.

3. Select a printer.

4. Press the Print button.

Printing From the Main Toolbar

1. Press the Print icon in the Main toolbar. 

• The Print Preview dialog opens.

2. Press the Print button.

• The Print dialog opens.

3. Select a printer.

4. Press the Print button.
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3-2 Instrument Setup & easyTest File Execution
At this point an easyTest file has been created and ready for use. The following instructions sets up the 
connections ports, transfers the easyTest file to the instrument, and executes the easyTest file sequence on the 
instrument.

Instrument Setup

There are two ways to connect by USB:

• Connect the PC to the Anritsu Handheld instrument with a USB cable. 

• Connect a USB drive with the easyTest file to USB port of instrument.

Ethernet Connection

1. Press the Shift then System buttons on the instrument.

2. Press the Status submenu button. 

3. Obtain the IP Address, the first line listed in the Status window.Connect the PC to the Anritsu 
Handheld instrument using an Ethernet cable. 

easyTest Tools File Transfer

1. Copy the eTT file from the PC onto a USB memory stick.

2. Copy the eTT file from the USB memory stick into the instrument. Please refer to your instrument’s File 
Management chapter, Copying Files section, for specific instructions regarding copying files between a 
USB memory stick and the instrument.

Executing the easyTest File

1. Press the Menu button on the Anritsu Handheld instrument keypad. 

2. Press the easyTest button   on the instrument.

• The Recall dialog opens.Select an easyTest file using the up/down arrows or knob.

3. Press Enter.

• The first step of the easyTest file is executed.

4. Follow the instruction prompts on the Status/Instruction bar. Example below. Press either the “Next 
Step” button on the touch screen or the right arrow button on the instrument to continue to the next 
step. 

• After completing the last step, an Attention dialog will inform you that the easyTest file sequence 
is completed and closing.

Communication Port Setup

1. Click Instrument Connection Settings… in the Settings menu or press Select Instrument Connection 
icon on the easyTest Tools toolbar. 

2. Select the connection type to the instrument.

• USB Connection – Selecting this option allows you to connect to the instrument using a USB 
Cable. Once connected you will be able to retrieve a setup file via the USB cable connection.

• Ethernet Connection – When selected, enter the IP address of the instrument in the text box. Once 
connected you will be able to retrieve a setup file via the Ethernet cable connection. 

3. Press the Save Settings button when done.
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Creating an easyTest File

1. Drag the desired step/s from the Command Selections panel into the Command Sequence panel. 

2. Remove unwanted commands from the Command Sequence panel by highlighting that command and 
pressing the Delete button on the PC keyboard.

3. Set the order of the commands in the Command Sequence panel by clicking on a command and dragging 
it to the desired 1-2-3… order.

4. Click Save As… in the File menu.

Editing an easyTest File

1. Click Open in the File menu or the File icon in the Main Toolbar. The Open dialog opens.

2. Select an .ett file and press Open.

3. Drag the desired step/s from the Command Selections panel into the Command Sequence panel. Remove 
unwanted commands from the Command Sequence panel by highlighting that command and pressing 
the Delete button on the PC keyboard.

4. Set the order of the commands in the Command Sequence panel by clicking on a command and dragging 
it to the desired 1-2-3… order.

5. Save options. Click Save… in the File menu or the Save icon on the Main toolbar to save the edits with 
the existing file name. Or, click Save As… in the File menu to save the edited command sequence as a 
new file.

Note
If a command’s parameters need editing, click on it in the Command Sequence panel and it will be 
displayed in the Command Detail panel. Change its parameters accordingly.

Note
If a command’s parameters need editing, click on it in the Command Sequence panel and it will be 
displayed in the Command Detail panel. Change its parameters accordingly.





 Anritsu utilizes recycled paper and environmentally conscious inks and toner.

Anritsu Company
490 Jarvis Drive
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